Problem description:
When ApexSQL Audit is uninstalled, some local files are leftover on the installation drive.
Cause:
By design, some files including the repository database .mdf and .ldf files, configuration files, application logs with processing history, UI settings as well as any unprocessed files containing auditing information and more remain in the installation directories to ensure no important information/files are removed on intentional uninstall, reinstall jobs.
Resolution:
After ApexSQL Audit is uninstalled from Control Panel\All Control Panel Items\Programs and Features, the following folders will still potentially hold legacy information related to ApexSQL Audit and need to be cleaned manually:
- Installation directory – by default settings, this is C:\Program Files\ApexSQL\ApexSQL Audit
- User data – %AppData%\Local\ApexSQL\ApexSQLAudit
- Documentation – by default it’s %Documents\ApexSQL\ApexSQL Audit
- Temporary data location – default location is C:\ProgramData\ApexSQL\ApexSQLAudit
- Server-side components – C:\ProgramData\ApexSQL\ApexSQLSSC
Final ‘remains’ of ApexSQL Audit after successful uninstallation are the central repository database and any repository archives that were created while the tool was running.
Important notice: removing repository database or archives will delete previously audited data, so it is suggested to always make sure that the data is indeed not needed anymore before initiating the deletion of repository and/or archives.
Deleting repository or archives is the same as deleting any other SQL Server database – simply connect to the SQL Server using SQL Server Management Studio (or similar tool) and initiate the deletion of an appropriate database.
With these, all ApexSQL Audit remains should be gone and the Server should be free of any ApexSQL Audit files.