How to change user accounts running ApexSQL Audit services/processes

Problem Description

The account running central or distributed service/process needs to be changed.

Cause

The general cause for this is encountered when user permissions are or need to be changed or similar.

Resolution

SOLUTION 1 – Central service/process

In order to change the login running the central service and the process, the application reinstall must be performed.

ApexSQL Audit can be installed either by:

  1. Running the ApexSQLAudit.exe installation file
  2. Running the ApexSQL.Audit.Installer.exe file from the installation directory (default location is C:\ProgramFiles\ApexSQL\ApexSQL Audit\ApexSQ.Audit.Installer.exe)

Regardless of the choice of re-install approach, the ApexSQL Audit central instance setup dialog is shown and will prompt for input.

To perform the installation process:

  1. Provide Username (ensure they have Windows administrator credentials)
  2. Enter Password
  3. Click on the Install button

Central instance properties setup

After short processing, ApexSQL Audit reinstall will be completed and service/process will now be running under newly configured login.

SOLUTION 2 – Distributed (remote) service/process

User login running the remote agent can be quickly changed from within ApexSQL Audit GUI.

To start the process:

  1. Start ApexSQL Audit and click on the Configure button in the main ribbon
  2. Select the SQL Server instance where the account that will be changed is running
  3. Click on the Edit button
  4. In the Auditing agent properties dialog, provide valid username and password
  5. Click OK to complete the process

Distributed auditing agent properties